10 Apr

Cloud Backup Solutions Security Update

A serious vulnerability in the OpenSSL library was published on April 7th 2014 as CVE-2014-0160. This bug is being referred to as Heartbleed and more information can be found at www.heartbleed.com.

This is the software that drives secure websites, sometimes referred to as SSL or HTTPS websites, and affects many millions of secure sites globally.

We would like to assure our customers that our Cloud Backup environment does not use OpenSSL, was not affected and your account and backup data remain safe.

Due to the nature of the bug we do recommend that you change your password on any secure websites that you use regularly to ensure that you are not compromised in any way, whilst also checking and confirming with banks, vendors, and companies you may use as most are issuing their own updates regarding this.

If you have any of your own servers or machines running variants of Unix outlined at www.heartbleed.com with web servers running SSL we recommend that you upgrade immediately and don’t forget to restart your web server after upgrading.